linux与QQ 一个没有尽头话题

2012年 06月 12日 11:39

linux下的QQ已经推出N个版本了,基本为第三方的,先后都归西了,也包括当年android刚起步的时候有个第三方的QQ(AQQ),腾讯官方当时未提供官方版本,等官方出了之后.也封杀了.
所以linux下使用QQ一直以来都是一件很蛋疼的事情.很多用户都放弃了QQ,但是身边的朋友都上这个.在天朝脱离QQ就像去了极乐世界一样了.虽然耳根子是清净了,但也差不多脱离这个社会了..

官方的linuxqq

这个版本官方已经禁用了..无法登陆了,保留这个文章因为,其中有个蛋疼的V..一定有人会遇到啊!
从LINUX QQ 官网下载 安装包 http://im.qq.com/qq/linux/download.shtml
我是UBUNTU 12.04 下的DEB包,双击deb包安装失败.

选择dpkg安装:方法

[email protected]:~/下载$ sudo dpkg -i linuxqq_v1.0.2-beta1_i386.deb 
[sudo] password for yingouqlj: 
dpkg:处理 linuxqq_v1.0.2-beta1_i386.deb (--install)时出错:
 parsing file '/var/lib/dpkg/tmp.ci/control' near line 7 package 'linuxqq:i386':
 版本字符串 v1.0.2-beta1 中有错误: version number does not start with digit
在处理时有错误发生:
 linuxqq_v1.0.2-beta1_i386.deb

解决方法去掉版本号的V
解压DEB包及控制文本,修改control中那个v并重新打包,再次安装即可完成.

[email protected]:~/下载$ dpkg-deb -x linuxqq_v1.0.2-beta1_i386.deb qq
[email protected]:~/下载$ dpkg-deb -e linuxqq_v1.0.2-beta1_i386.deb qq/DEBIAN
[email protected]:~/下载$ dpkg-deb -b qq linuxqq.deb
dpkg-deb:正在新建软件包 linuxqq:i386,包文件为 linuxqq.deb。
[email protected]:~/下载$ sudo dpkg -i linuxqq.deb
Selecting previously unselected package linuxqq:i386.
(正在读取数据库 ... 系统当前共安装有 249168 个文件和目录。)
正在解压缩 linuxqq:i386 (从 qq.deb) ...
正在设置 linuxqq:i386 (1.0.2-beta1) ...
正在处理用于 bamfdaemon 的触发器...
Rebuilding /usr/share/applications/bamf.index...
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 gnome-menus 的触发器...

官方的LINUXQQ一直都不太稳定.目前已经无法使用了

选区_808.png

不过代替品WEBQQ还不错 http://web.qq.com

第三方插件libqq

这个版本,也有问题,会封号.
下面是源的安装,我是懒人.

sudo add-apt-repository ppa:lainme/libqq
sudo apt-get update
sudo apt-get install libqq-pidgin
选区_786.png

我的empathy是3.4的顺便更新到新的3.6吧.可无视这里

sudo add-apt-repository ppa:telepathy/ppa
sudo apt-get update && sudo apt-get upgrade

基于pidgin的webqq pidgin-lwqq

我是ubuntu12.04,ubuntu从8就替换了pidgin为empathy.但是empathy并不支持群组,所以你装了插件,empathy支持的很不好,不过可以登陆.跟聊天,不过不好用.

选区_793.png

建议安装pidgin,支持群,以及能现实手机状态等.几乎完美了.顺便附上pidgin的源.

sudo add-apt-repository ppa:lainme/pidgin-lwqq
sudo apt-get update
sudo apt-get install libpurple0 pidgin-lwqq

sudo add-apt-repository ppa:pidgin-developers/ppa
sudo apt-get update

目前来说,这个可行.比较完美了.不过问题也多,好友多初始化卡,

好友提醒 工具->插件->libnotify 提醒 根据自己需要配置吧,那个该死的好友上线太麻烦了..老跳

*不足之处是,无法屏蔽群,所有的都提醒,好在窗口是合并标签的,所以无太大困扰
*部分联系人无法显示名字,无法显示名字的无法发送消息 *初始化老卡死(可能根好友数量有关)

总之,一般建议使用WEBQQ 用于接受提醒 LWQQ 很好.

相关文章